Age | Commit message (Expand) | Author | Files | Lines |
2017-08-23 | powerpc: Convert to using %pOF instead of full_name | Rob Herring | 1 | -3/+3 |
2016-06-21 | powerpc/pci: Delay populating pdn | Gavin Shan | 1 | -14/+24 |
2015-04-11 | powerpc/powermac: Move controller ops from ppc_md to controller_ops | Daniel Axtens | 1 | -2/+15 |
2015-04-11 | powerpc: pcibios_enable_device_hook: return bool rather than int | Daniel Axtens | 1 | -4/+4 |
2015-04-11 | powerpc/powermac: move pmac_pci_probe_mode from setup.c to pci.c | Daniel Axtens | 1 | -0/+17 |
2015-01-31 | powerpc/powermac: Convert PCI to use generic config accessors | Rob Herring | 1 | -170/+39 |
2014-11-10 | powerpc: Remove superfluous bootmem includes | Anton Blanchard | 1 | -1/+0 |
2014-06-26 | of: Migrate of_find_node_by_name() users to for_each_node_by_name() | Grant Likely | 1 | -1/+1 |
2013-05-06 | powerpc/pci: Support per-aperture memory offset | Benjamin Herrenschmidt | 1 | -1/+1 |
2013-01-04 | POWERPC: drivers: remove __dev* attributes. | Greg Kroah-Hartman | 1 | -3/+3 |
2012-02-24 | powerpc/PCI: make pci_probe_only default to 0 | Bjorn Helgaas | 1 | -3/+0 |
2011-09-30 | powerpc: Fix device-tree matching for Apple U4 bridge | Benjamin Herrenschmidt | 1 | -0/+14 |
2011-07-27 | Merge branch 'next/cross-platform' of git://git.kernel.org/pub/scm/linux/kern... | Linus Torvalds | 1 | -3/+3 |
2011-07-26 | Merge branch 'for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/jik... | Linus Torvalds | 1 | -4/+2 |
2011-07-12 | powerpc: rename ppc_pci_*_flags to pci_*_flags | Rob Herring | 1 | -3/+3 |
2011-06-10 | treewide: Convert uses of struct resource to resource_size(ptr) | Joe Perches | 1 | -4/+2 |
2011-06-08 | pci/of: Match PCI devices to OF nodes dynamically | Benjamin Herrenschmidt | 1 | -1/+2 |
2011-03-31 | Fix common misspellings | Lucas De Marchi | 1 | -1/+1 |
2011-03-29 | powerpc: Convert to new irq_* function names | Thomas Gleixner | 1 | -1/+1 |
2010-08-24 | powerpc/powermac: Drop unnecessary of_node_put | Julia Lawall | 1 | -2/+0 |
2009-12-04 | tree-wide: fix assorted typos all over the place | André Goddard Rosa | 1 | -1/+1 |
2009-09-02 | powerpc: Fix some late PowerMac G5 with PCIe ATI graphics | Benjamin Herrenschmidt | 1 | -0/+61 |
2009-01-08 | powerpc/powermac: Add missing of_node_put | Nicolas Palix | 1 | -0/+2 |
2008-12-16 | powerpc: Introduce ppc_pci_flags accessors | Josh Boyer | 1 | -3/+3 |
2008-04-18 | ppc/pmac: remove no longer needed IDE quirk | Bartlomiej Zolnierkiewicz | 1 | -22/+0 |
2007-12-20 | [POWERPC] Improve resource setup of PowerMac G5 HT bridge | Benjamin Herrenschmidt | 1 | -78/+64 |
2007-12-20 | [POWERPC] Enable self-view of the HT host bridge on PowerMac G5 | Benjamin Herrenschmidt | 1 | -19/+35 |
2007-12-20 | [POWERPC] Clear pci_probe_only on 64 bits PowerMac | Benjamin Herrenschmidt | 1 | -2/+2 |
2007-12-20 | [POWERPC] Fixup powermac enable device hook | Benjamin Herrenschmidt | 1 | -4/+14 |
2007-12-20 | [POWERPC] Merge 32 and 64 bits pcibios_enable_device | Benjamin Herrenschmidt | 1 | -12/+10 |
2007-12-20 | [POWERPC] Merge PCI resource allocation & assignment | Benjamin Herrenschmidt | 1 | -2/+1 |
2007-12-20 | [POWERPC] pci32: Add flags modifying the PCI code behaviour | Benjamin Herrenschmidt | 1 | -2/+5 |
2007-12-11 | Merge branch 'linux-2.6' into for-2.6.25 | Paul Mackerras | 1 | -2/+9 |
2007-12-11 | [POWERPC] pci_controller->arch_data really is a struct device_node * | Stephen Rothwell | 1 | -3/+3 |
2007-12-10 | powerpc: Fix IDE legacy vs. native fixups | Benjamin Herrenschmidt | 1 | -2/+9 |
2007-08-17 | [POWERPC] Remove gratuitous reads from powermac pci config space methods | Nathan Lynch | 1 | -9/+0 |
2007-08-17 | [POWERPC] powermac pci_ops: Use named structure member initializers | Nathan Lynch | 1 | -8/+8 |
2007-06-29 | [POWERPC] Merge ppc32 and ppc64 pcibios_alloc_controller() prototypes | Kumar Gala | 1 | -6/+0 |
2007-06-29 | [POWERPC] rename add_bridge to avoid namespace clashes | Arnd Bergmann | 1 | -5/+3 |
2007-06-14 | [POWERPC] Rewrite IO allocation & mapping on powerpc64 | Benjamin Herrenschmidt | 1 | -32/+0 |
2007-05-07 | [POWERPC] Rename device_is_compatible to of_device_is_compatible | Stephen Rothwell | 1 | -15/+15 |
2007-04-24 | [POWERPC] Remove old interface find_devices | Stephen Rothwell | 1 | -11/+12 |
2007-04-12 | [POWERPC] Rename get_property to of_get_property: arch/powerpc | Stephen Rothwell | 1 | -8/+8 |
2007-04-12 | [POWERPC] Make struct property's value a void * | Stephen Rothwell | 1 | -1/+1 |
2007-03-07 | [POWERPC] Fix warning in powermac pci.c | Benjamin Herrenschmidt | 1 | -2/+5 |
2006-12-04 | [POWERPC] Make pci_read_irq_line the default | Benjamin Herrenschmidt | 1 | -21/+14 |
2006-12-02 | PCI: Delete unused extern in powermac/pci.c | Matthew Wilcox | 1 | -1/+0 |
2006-08-01 | Merge branch 'merge' | Paul Mackerras | 1 | -6/+7 |
2006-07-31 | [POWERPC] powermac: Constify & voidify get_property() | Jeremy Kerr | 1 | -17/+20 |
2006-07-11 | [PATCH] powerpc: fix trigger handling in the new irq code | Benjamin Herrenschmidt | 1 | -6/+7 |