summaryrefslogtreecommitdiff
path: root/meta-ufispace/meta-common/recipes-phosphor/network/usb-network.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ufispace/meta-common/recipes-phosphor/network/usb-network.bb')
-rw-r--r--meta-ufispace/meta-common/recipes-phosphor/network/usb-network.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-ufispace/meta-common/recipes-phosphor/network/usb-network.bb b/meta-ufispace/meta-common/recipes-phosphor/network/usb-network.bb
new file mode 100644
index 0000000000..14d84864cb
--- /dev/null
+++ b/meta-ufispace/meta-common/recipes-phosphor/network/usb-network.bb
@@ -0,0 +1,27 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}"
+SRC_URI += "file://usb-network.sh \
+ file://usb-network.service \
+ file://00-bmc-usb0.network"
+
+inherit allarch systemd
+
+DEPENDS += "systemd"
+RDEPENDS:${PN} += "libsystemd bash"
+
+FILES:${PN} += "${sysconfdir_native}/systemd/network/00-bmc-usb0.network"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${WORKDIR}/usb-network.sh ${D}/${sbindir}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/usb-network.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sysconfdir_native}/systemd/network/
+ install -m 0644 ${WORKDIR}/00-bmc-usb0.network ${D}${sysconfdir_native}/systemd/network
+}
+
+SYSTEMD_SERVICE:${PN} = "usb-network.service"