summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/inventory
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/inventory')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager/associations.json230
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend10
2 files changed, 240 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager/associations.json b/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager/associations.json
new file mode 100644
index 0000000000..5f9e57a551
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager/associations.json
@@ -0,0 +1,230 @@
+[
+ {
+ "path": "system/chassis/Mt_Jade/FAN3",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/FAN3_1",
+ "/xyz/openbmc_project/sensors/fan_tach/FAN3_2"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "cooled_by",
+ "fType": "cooling"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/inventory/system/chassis"
+ ]
+ },
+ {
+ "types": {
+ "rType": "fault_identified_by",
+ "fType": "fault_identifying"
+ },
+ "paths": [
+ "/xyz/openbmc_project/led/groups/fan_fault"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/Mt_Jade/FAN4",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/FAN4_1",
+ "/xyz/openbmc_project/sensors/fan_tach/FAN4_2"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "cooled_by",
+ "fType": "cooling"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/inventory/system/chassis"
+ ]
+ },
+ {
+ "types": {
+ "rType": "fault_identified_by",
+ "fType": "fault_identifying"
+ },
+ "paths": [
+ "/xyz/openbmc_project/led/groups/fan_fault"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/Mt_Jade/FAN5",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/FAN5_1",
+ "/xyz/openbmc_project/sensors/fan_tach/FAN5_2"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "cooled_by",
+ "fType": "cooling"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/inventory/system/chassis"
+ ]
+ },
+ {
+ "types": {
+ "rType": "fault_identified_by",
+ "fType": "fault_identifying"
+ },
+ "paths": [
+ "/xyz/openbmc_project/led/groups/fan_fault"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/Mt_Jade/FAN6",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/FAN6_1",
+ "/xyz/openbmc_project/sensors/fan_tach/FAN6_2"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "cooled_by",
+ "fType": "cooling"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/inventory/system/chassis"
+ ]
+ },
+ {
+ "types": {
+ "rType": "fault_identified_by",
+ "fType": "fault_identifying"
+ },
+ "paths": [
+ "/xyz/openbmc_project/led/groups/fan_fault"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/Mt_Jade/FAN7",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/FAN7_1",
+ "/xyz/openbmc_project/sensors/fan_tach/FAN7_2"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "cooled_by",
+ "fType": "cooling"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/inventory/system/chassis"
+ ]
+ },
+ {
+ "types": {
+ "rType": "fault_identified_by",
+ "fType": "fault_identifying"
+ },
+ "paths": [
+ "/xyz/openbmc_project/led/groups/fan_fault"
+ ]
+ }
+ ]
+ },
+ {
+ "path": "system/chassis/Mt_Jade/FAN8",
+ "endpoints":
+ [
+ {
+ "types":
+ {
+ "rType": "inventory",
+ "fType": "sensors"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/sensors/fan_tach/FAN8_1",
+ "/xyz/openbmc_project/sensors/fan_tach/FAN8_2"
+ ]
+ },
+ {
+ "types":
+ {
+ "rType": "cooled_by",
+ "fType": "cooling"
+ },
+ "paths":
+ [
+ "/xyz/openbmc_project/inventory/system/chassis"
+ ]
+ },
+ {
+ "types": {
+ "rType": "fault_identified_by",
+ "fType": "fault_identifying"
+ },
+ "paths": [
+ "/xyz/openbmc_project/led/groups/fan_fault"
+ ]
+ }
+ ]
+ }
+] \ No newline at end of file
diff --git a/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
new file mode 100644
index 0000000000..768c66758f
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -0,0 +1,10 @@
+DEPENDS:append = " inventory-cleanup"
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+PACKAGECONFIG:append = " associations"
+SRC_URI:append = " file://associations.json"
+
+do_install:append() {
+ install -d ${D}${base_datadir}
+ install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}
+}