summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2024-08-14 15:02:03 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-08-19 18:14:52 +0300
commitb473c498675fa7c86b5b573bd6bf8ef5c2999917 (patch)
tree101efa0a3a3ac3e056045cf18ba04eeeb7d49bb3 /meta-facebook
parent16bdead1cadc7108b6fb043ffa5846b1b1fb7ac3 (diff)
downloadopenbmc-b473c498675fa7c86b5b573bd6bf8ef5c2999917.tar.xz
meta-facebook: catalina: add phosphor-multi-gpio-presence config
Add phosphor-multi-gpio-presence.json to enable presence pin monitoring. Test results: ``` { "@odata.id": "/redfish/v1/Cables", "@odata.type": "#CableCollection.CableCollection", "Description": "Collection of Cable Entries", "Members": [ { "@odata.id": "/redfish/v1/Cables/FIORJ45Cable" }, { "@odata.id": "/redfish/v1/Cables/HDDPowerCable" }, { "@odata.id": "/redfish/v1/Cables/LeakCable0" }, { "@odata.id": "/redfish/v1/Cables/LeakCable1" }, { "@odata.id": "/redfish/v1/Cables/LeakCable2" }, { "@odata.id": "/redfish/v1/Cables/LeakCable3" }, { "@odata.id": "/redfish/v1/Cables/OSFPPowerCable" } ], "Members@odata.count": 7, "Name": "Cable Collection" } ``` Change-Id: I6942dd3bb32ee8f2da92849441fe229bc0005dd5 Signed-off-by: Potin Lai <potin.lai@quantatw.com>
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json99
-rw-r--r--meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend4
2 files changed, 102 insertions, 1 deletions
diff --git a/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json b/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json
new file mode 100644
index 0000000000..f4f73feff7
--- /dev/null
+++ b/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor/phosphor-multi-gpio-presence.json
@@ -0,0 +1,99 @@
+[
+ {
+ "Name": "Fan0",
+ "LineName": "FAN_0_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan0"
+ },
+ {
+ "Name": "Fan1",
+ "LineName": "FAN_1_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan1"
+ },
+ {
+ "Name": "Fan2",
+ "LineName": "FAN_2_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan2"
+ },
+ {
+ "Name": "Fan3",
+ "LineName": "FAN_3_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan3"
+ },
+ {
+ "Name": "Fan4",
+ "LineName": "FAN_4_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan4"
+ },
+ {
+ "Name": "Fan5",
+ "LineName": "FAN_5_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan5"
+ },
+ {
+ "Name": "Fan6",
+ "LineName": "FAN_6_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan6"
+ },
+ {
+ "Name": "Fan6",
+ "LineName": "FAN_7_PRESENT_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/Catalina/Fan7"
+ },
+ {
+ "Name": "LeakCable0",
+ "LineName": "PRSNT_CHASSIS0_LEAK_CABLE_R_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/LeakCable0",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ },
+ {
+ "Name": "LeakCable1",
+ "LineName": "PRSNT_CHASSIS1_LEAK_CABLE_R_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/LeakCable1",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ },
+ {
+ "Name": "LeakCable2",
+ "LineName": "PRSNT_CHASSIS2_LEAK_CABLE_R_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/LeakCable2",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ },
+ {
+ "Name": "LeakCable3",
+ "LineName": "PRSNT_CHASSIS3_LEAK_CABLE_R_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/LeakCable3",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ },
+ {
+ "Name": "OSFPPowerCable",
+ "LineName": "PRSNT_OSFP_POWER_CABLE_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/OSFPPowerCable",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ },
+ {
+ "Name": "HDDPowerCable",
+ "LineName": "PRSNT_HDDBD_POWER_CABLE_N",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/HDDPowerCable",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ },
+ {
+ "Name": "FIORJ45Cable",
+ "LineName": "PRSNT_RJ45_FIO_N_R",
+ "ActiveLow": true,
+ "Inventory": "/system/chassis/compute_tray/cable/FIORJ45Cable",
+ "ExtraInterfaces": ["xyz.openbmc_project.Inventory.Item.Cable"]
+ }
+]
diff --git a/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index e4ebc9274e..1fce94b731 100644
--- a/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-facebook/meta-catalina/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -25,6 +25,8 @@ do_install:append:() {
install -d ${D}${libexecdir}/${PN}
install -m 0644 ${WORKDIR}/phosphor-multi-gpio-monitor.json \
- ${D}${datadir}/phosphor-gpio-monitor/phosphor-multi-gpio-monitor.json
+ ${D}${datadir}/${PN}/phosphor-multi-gpio-monitor.json
+ install -m 0644 ${WORKDIR}/phosphor-multi-gpio-presence.json \
+ ${D}${datadir}/${PN}/phosphor-multi-gpio-presence.json
install -m 0755 ${WORKDIR}/catalina-gpio-monitor ${D}${libexecdir}/${PN}/catalina-gpio-monitor
}