summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorYang Chen <yang.chen@quantatw.com>2024-08-29 06:03:46 +0300
committerAmithash Prasad <amithash@meta.com>2024-09-05 00:51:20 +0300
commit4450e28e8d45ae707ce3bedf0dba429a709d165f (patch)
treea638bf2c30d93abaed573479e367322da57508ef /meta-facebook
parent6b799c3271e84bc5b10e212d50f73f231e40ba40 (diff)
downloadopenbmc-4450e28e8d45ae707ce3bedf0dba429a709d165f.tar.xz
meta-facebook: minerva: Add blacklist config in entity-manager
Due to the CPLD on the fan board change to the XO5 starting from the DVT stage, we changed the update mechanism on it and we found that it caused the i2c bus to hang by FRUDevice initial process. So we add the i2c address of the CPLD update in the blacklist configuration to avoid this problem. Change-Id: I55cca8ecfdc9fb84632a6cb3c2c30707ac2fef92 Signed-off-by: Yang Chen <yang.chen@quantatw.com>
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager/blacklist.json28
-rw-r--r--meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager_%.bbappend11
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager/blacklist.json b/meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager/blacklist.json
new file mode 100644
index 0000000000..8ece28787f
--- /dev/null
+++ b/meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager/blacklist.json
@@ -0,0 +1,28 @@
+{
+ "buses": [
+ {
+ "bus": 16,
+ "addresses": [ "0x51"]
+ },
+ {
+ "bus": 17,
+ "addresses": [ "0x51"]
+ },
+ {
+ "bus": 18,
+ "addresses": [ "0x51"]
+ },
+ {
+ "bus": 19,
+ "addresses": [ "0x51"]
+ },
+ {
+ "bus": 20,
+ "addresses": [ "0x51"]
+ },
+ {
+ "bus": 21,
+ "addresses": [ "0x51"]
+ }
+ ]
+}
diff --git a/meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager_%.bbappend
new file mode 100644
index 0000000000..26e599094c
--- /dev/null
+++ b/meta-facebook/meta-minerva/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+inherit obmc-phosphor-systemd systemd
+
+SRC_URI += "\
+ file://blacklist.json \
+ "
+
+do_install:append() {
+ install -m 0644 -D ${WORKDIR}/blacklist.json ${D}${datadir}/${PN}/blacklist.json
+}