summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-bletchley
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/meta-bletchley')
-rw-r--r--meta-facebook/meta-bletchley/conf/local.conf.sample5
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch31
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend5
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend5
4 files changed, 42 insertions, 4 deletions
diff --git a/meta-facebook/meta-bletchley/conf/local.conf.sample b/meta-facebook/meta-bletchley/conf/local.conf.sample
index bb86f3418..0c5e4cd5f 100644
--- a/meta-facebook/meta-bletchley/conf/local.conf.sample
+++ b/meta-facebook/meta-bletchley/conf/local.conf.sample
@@ -126,12 +126,9 @@ EXTRA_IMAGE_FEATURES = "debug-tweaks"
# enable extra features. Some available options which can be included in this variable
# are:
# - 'buildstats' collect build statistics
-# - 'image-mklibs' to reduce shared library files size for an image
# - 'image-prelink' in order to prelink the filesystem image
# - 'image-swab' to perform host system intrusion detection
-# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
-# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+USER_CLASSES ?= "buildstats image-prelink"
#
# Runtime testing of images
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch
new file mode 100644
index 000000000..46f892908
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch
@@ -0,0 +1,31 @@
+From 12e9371e44b922e0383dba3a231a21b82ca03368 Mon Sep 17 00:00:00 2001
+From: Howard <howard.chiu@quantatw.com>
+Date: Wed, 4 Aug 2021 14:08:14 +0800
+Subject: [PATCH] u-boot: ast2600: 57600 baudrate for bletchley
+
+Specific patch for bletchley only
+---
+ configs/ast2600_openbmc_spl_defconfig | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configs/ast2600_openbmc_spl_defconfig b/configs/ast2600_openbmc_spl_defconfig
+index c1ed4f54d5..2257673e16 100644
+--- a/configs/ast2600_openbmc_spl_defconfig
++++ b/configs/ast2600_openbmc_spl_defconfig
+@@ -35,7 +35,7 @@ CONFIG_ARMV7_PSCI_NR_CPUS=2
+ CONFIG_NR_DRAM_BANKS=1
+ CONFIG_FIT=y
+ CONFIG_USE_BOOTARGS=y
+-CONFIG_BOOTARGS="console=ttyS4,115200n8 root=/dev/ram rw"
++CONFIG_BOOTARGS="console=ttyS4,57600n8 root=/dev/ram rw"
+ CONFIG_USE_BOOTCOMMAND=y
+ CONFIG_BOOTCOMMAND="bootm 20100000"
+ CONFIG_SYS_CONSOLE_ENV_OVERWRITE=y
+@@ -133,3 +133,4 @@ CONFIG_USE_TINY_PRINTF=y
+ CONFIG_TPM=y
+ CONFIG_SPL_TPM=y
+ # CONFIG_EFI_LOADER is not set
++CONFIG_BAUDRATE=57600
+--
+2.25.1
+
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
new file mode 100644
index 000000000..2789df998
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch \
+ "
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
new file mode 100644
index 000000000..b7bdbd200
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-aspeed-sdk:"
+
+SRC_URI += " \
+ file://0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch \
+ "