summaryrefslogtreecommitdiff
path: root/drivers/iommu/Makefile
diff options
context:
space:
mode:
authorJoerg Roedel <jroedel@suse.de>2020-06-09 16:03:02 +0300
committerJoerg Roedel <jroedel@suse.de>2020-06-10 18:46:42 +0300
commitad8694bac410e5d72ad610dfb146f58bf2fe0365 (patch)
tree789fdd8ef996bef00a44a8a31aa4649b2f39f065 /drivers/iommu/Makefile
parent431275afdc7155415254aef4bd3816a1b8a2ead0 (diff)
downloadlinux-ad8694bac410e5d72ad610dfb146f58bf2fe0365.tar.xz
iommu/amd: Move AMD IOMMU driver into subdirectory
Move all files related to the AMD IOMMU driver into its own subdirectory. Signed-off-by: Joerg Roedel <jroedel@suse.de> Reviewed-by: Suravee Suthikulpanit <suravee.suthikulpanit@amd.com> Reviewed-by: Jerry Snitselaar <jsnitsel@redhat.com> Link: https://lore.kernel.org/r/20200609130303.26974-2-joro@8bytes.org
Diffstat (limited to 'drivers/iommu/Makefile')
-rw-r--r--drivers/iommu/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/drivers/iommu/Makefile b/drivers/iommu/Makefile
index 57cf4ba5e27c..3af7e374b0cb 100644
--- a/drivers/iommu/Makefile
+++ b/drivers/iommu/Makefile
@@ -11,9 +11,9 @@ obj-$(CONFIG_IOASID) += ioasid.o
obj-$(CONFIG_IOMMU_IOVA) += iova.o
obj-$(CONFIG_OF_IOMMU) += of_iommu.o
obj-$(CONFIG_MSM_IOMMU) += msm_iommu.o
-obj-$(CONFIG_AMD_IOMMU) += amd_iommu.o amd_iommu_init.o amd_iommu_quirks.o
-obj-$(CONFIG_AMD_IOMMU_DEBUGFS) += amd_iommu_debugfs.o
-obj-$(CONFIG_AMD_IOMMU_V2) += amd_iommu_v2.o
+obj-$(CONFIG_AMD_IOMMU) += amd/iommu.o amd/init.o amd/quirks.o
+obj-$(CONFIG_AMD_IOMMU_DEBUGFS) += amd/debugfs.o
+obj-$(CONFIG_AMD_IOMMU_V2) += amd/iommu_v2.o
obj-$(CONFIG_ARM_SMMU) += arm_smmu.o
arm_smmu-objs += arm-smmu.o arm-smmu-impl.o arm-smmu-qcom.o
obj-$(CONFIG_ARM_SMMU_V3) += arm-smmu-v3.o