summaryrefslogtreecommitdiff
path: root/drivers/iio/adc/Makefile
diff options
context:
space:
mode:
authorTomislav Denis <tomislav.denis@avl.com>2021-02-02 11:41:06 +0300
committerJonathan Cameron <Jonathan.Cameron@huawei.com>2021-03-11 23:46:58 +0300
commitd935eddd2799f2559d3c909e5977c0a85a5af1b7 (patch)
tree46223ffe691b2e9ed3bc550f7a365407bcc40aff /drivers/iio/adc/Makefile
parentc19ae6be7555abbee985d73372d0e78878a337f8 (diff)
downloadlinux-d935eddd2799f2559d3c909e5977c0a85a5af1b7.tar.xz
iio: adc: Add driver for Texas Instruments ADS131E0x ADC family
The ADS131E0x are a family of multichannel, simultaneous sampling, 24-bit, delta-sigma, analog-to-digital converters (ADCs) with a built-in programmable gain amplifier (PGA), internal reference and an onboard oscillator. Datasheet: https://www.ti.com/lit/ds/symlink/ads131e08.pdf Signed-off-by: Tomislav Denis <tomislav.denis@avl.com> Link: https://lore.kernel.org/r/20210202084107.3260-2-tomislav.denis@avl.com Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Diffstat (limited to 'drivers/iio/adc/Makefile')
-rw-r--r--drivers/iio/adc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/drivers/iio/adc/Makefile b/drivers/iio/adc/Makefile
index 5fca90ada0ec..a226657d19c0 100644
--- a/drivers/iio/adc/Makefile
+++ b/drivers/iio/adc/Makefile
@@ -103,6 +103,7 @@ obj-$(CONFIG_TI_ADS7950) += ti-ads7950.o
obj-$(CONFIG_TI_ADS8344) += ti-ads8344.o
obj-$(CONFIG_TI_ADS8688) += ti-ads8688.o
obj-$(CONFIG_TI_ADS124S08) += ti-ads124s08.o
+obj-$(CONFIG_TI_ADS131E08) += ti-ads131e08.o
obj-$(CONFIG_TI_AM335X_ADC) += ti_am335x_adc.o
obj-$(CONFIG_TI_TLC4541) += ti-tlc4541.o
obj-$(CONFIG_TWL4030_MADC) += twl4030-madc.o