summaryrefslogtreecommitdiff
path: root/drivers/iio/adc/Makefile
diff options
context:
space:
mode:
authorMarkus Pargmann <mpa@pengutronix.de>2015-12-14 16:53:51 +0300
committerLee Jones <lee.jones@linaro.org>2016-02-11 18:40:41 +0300
commit6df2e98c3ea567bd15b46369180266d4c4df3447 (patch)
tree3893e532f32d237c16026b434589cf3f99c4e108 /drivers/iio/adc/Makefile
parente2fccf5c15157218f0b6488168f98183f82c1eda (diff)
downloadlinux-6df2e98c3ea567bd15b46369180266d4c4df3447.tar.xz
iio: adc: Add imx25-gcq ADC driver
This is a conversion queue driver for the mx25 SoC. It uses the central ADC which is used by two seperate independent queues. This driver prepares different conversion configurations for each possible input. For a conversion it creates a conversionqueue of one item with the correct configuration for the chosen channel. It then executes the queue once and disables the conversion queue afterwards. The reference voltages are configurable through devicetree subnodes, depending on the connections of the ADC inputs. Signed-off-by: Markus Pargmann <mpa@pengutronix.de> Signed-off-by: Denis Carikli <denis@eukrea.com> Acked-by: Jonathan Cameron <jic23@kernel.org> Signed-off-by: Lee Jones <lee.jones@linaro.org>
Diffstat (limited to 'drivers/iio/adc/Makefile')
-rw-r--r--drivers/iio/adc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/drivers/iio/adc/Makefile b/drivers/iio/adc/Makefile
index 6435780e9b71..151088f03258 100644
--- a/drivers/iio/adc/Makefile
+++ b/drivers/iio/adc/Makefile
@@ -19,6 +19,7 @@ obj-$(CONFIG_BERLIN2_ADC) += berlin2-adc.o
obj-$(CONFIG_CC10001_ADC) += cc10001_adc.o
obj-$(CONFIG_DA9150_GPADC) += da9150-gpadc.o
obj-$(CONFIG_EXYNOS_ADC) += exynos_adc.o
+obj-$(CONFIG_FSL_MX25_ADC) += fsl-imx25-gcq.o
obj-$(CONFIG_HI8435) += hi8435.o
obj-$(CONFIG_IMX7D_ADC) += imx7d_adc.o
obj-$(CONFIG_INA2XX_ADC) += ina2xx-adc.o