summaryrefslogtreecommitdiff
path: root/arch/mips/pci/Makefile
diff options
context:
space:
mode:
authorPaul Burton <paul.burton@imgtec.com>2016-10-05 20:18:13 +0300
committerRalf Baechle <ralf@linux-mips.org>2016-10-06 19:00:52 +0300
commit87dd9a4de421f052fd9be58c7da08a453f340d5e (patch)
treed59e67442805343710c679a14f7883759564912d /arch/mips/pci/Makefile
parentc5611df968047fb0b38156497b4242730ef66108 (diff)
downloadlinux-87dd9a4de421f052fd9be58c7da08a453f340d5e.tar.xz
MIPS: PCI: Support generic drivers
Introduce support for PCI drivers using only functionality provided generically by the PCI subsystem, by adding the minimum arch-provided functions required. The driver this has been developed for & tested with the xilinx-pcie on a MIPS Boston development board. Signed-off-by: Paul Burton <paul.burton@imgtec.com> Cc: linux-mips@linux-mips.org Patchwork: https://patchwork.linux-mips.org/patch/14346/ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
Diffstat (limited to 'arch/mips/pci/Makefile')
-rw-r--r--arch/mips/pci/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/arch/mips/pci/Makefile b/arch/mips/pci/Makefile
index 847821040cd9..4b821481dd44 100644
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
@@ -4,6 +4,7 @@
obj-y += pci.o
obj-$(CONFIG_PCI_DRIVERS_LEGACY)+= pci-legacy.o
+obj-$(CONFIG_PCI_DRIVERS_GENERIC)+= pci-generic.o
#
# PCI bus host bridge specific code