diff options
author | Martin Michlmayr <tbm@cyrius.com> | 2006-01-28 21:38:15 +0300 |
---|---|---|
committer | Sam Ravnborg <sam@mars.ravnborg.org> | 2006-02-19 11:51:19 +0300 |
commit | 8999257c292cb757828ae3def9f5e9d894a24741 (patch) | |
tree | e4c363dd3cf73784423f652aa3e4bfe5d09c6734 /Makefile | |
parent | 379b5441aeb895fe55b877a8a9c187e8728f774c (diff) | |
download | linux-8999257c292cb757828ae3def9f5e9d894a24741.tar.xz |
kbuild: Accept various mips sub-types in SUBARCH
uname -m on MIPS can give a number of results, such as mips64. We
need to add another substitution to the sed call for SUBARCH in the
main Makefile.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -151,7 +151,7 @@ export srctree objtree VPATH TOPDIR SUBARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \ -e s/arm.*/arm/ -e s/sa110/arm/ \ -e s/s390x/s390/ -e s/parisc64/parisc/ \ - -e s/ppc.*/powerpc/ ) + -e s/ppc.*/powerpc/ -e s/mips.*/mips/ ) # Cross compiling and selecting different set of gcc/bin-utils # --------------------------------------------------------------------------- |