diff options
author | Linus Torvalds <torvalds@linux-foundation.org> | 2021-05-28 21:31:48 +0300 |
---|---|---|
committer | Linus Torvalds <torvalds@linux-foundation.org> | 2021-05-28 21:31:48 +0300 |
commit | 8508b97ae2b6c73c2c09798c9fa9d27ec57ff1dc (patch) | |
tree | a5dcf52347b95a669857c9b66d51ddeed8a3783e /Makefile | |
parent | afdd14704d7eb4d7634cb7ba8d117066fed44282 (diff) | |
parent | 24845dcb170e16b3100bd49743687648c71387ae (diff) | |
download | linux-8508b97ae2b6c73c2c09798c9fa9d27ec57ff1dc.tar.xz |
Merge tag 'clang-features-v5.13-rc4' of git://git.kernel.org/pub/scm/linux/kernel/git/kees/linux
Pull clang feature fixes from Kees Cook:
- Correctly pass stack frame size checking under LTO (Nick Desaulniers)
- Avoid CFI mismatches by checking initcall_t types (Marco Elver)
* tag 'clang-features-v5.13-rc4' of git://git.kernel.org/pub/scm/linux/kernel/git/kees/linux:
Makefile: LTO: have linker check -Wframe-larger-than
init: verify that function is initcall_t at compile-time
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -928,6 +928,11 @@ CC_FLAGS_LTO += -fvisibility=hidden # Limit inlining across translation units to reduce binary size KBUILD_LDFLAGS += -mllvm -import-instr-limit=5 + +# Check for frame size exceeding threshold during prolog/epilog insertion. +ifneq ($(CONFIG_FRAME_WARN),0) +KBUILD_LDFLAGS += -plugin-opt=-warn-stack-size=$(CONFIG_FRAME_WARN) +endif endif ifdef CONFIG_LTO |