diff options
author | Stephen Rothwell <sfr@canb.auug.org.au> | 2018-08-31 00:47:28 +0300 |
---|---|---|
committer | Linus Torvalds <torvalds@linux-foundation.org> | 2018-08-31 04:15:34 +0300 |
commit | 217c3e0196758662aa0429863b09d1c13da1c5d6 (patch) | |
tree | 393862fb559905ec54a5a130ec665c716b48f6b4 /Makefile | |
parent | b6935d2aa49dabff296680a6f349b32e5a16afe0 (diff) | |
download | linux-217c3e0196758662aa0429863b09d1c13da1c5d6.tar.xz |
disable stringop truncation warnings for now
They are too noisy
Signed-off-by: Stephen Rothwell <sfr@canb.auug.org.au>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -807,6 +807,9 @@ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,) # disable pointer signed / unsigned warnings in gcc 4.0 KBUILD_CFLAGS += $(call cc-disable-warning, pointer-sign) +# disable stringop warnings in gcc 8+ +KBUILD_CFLAGS += $(call cc-disable-warning, stringop-truncation) + # disable invalid "can't wrap" optimizations for signed / pointers KBUILD_CFLAGS += $(call cc-option,-fno-strict-overflow) |