diff options
author | Masahiro Yamada <yamada.masahiro@socionext.com> | 2019-02-19 12:33:04 +0300 |
---|---|---|
committer | Masahiro Yamada <yamada.masahiro@socionext.com> | 2019-02-27 15:40:09 +0300 |
commit | 1e5ff84ffe0b09f866761c441003c27ca7e1c6b3 (patch) | |
tree | 11b4db4549af9078b96adc6376aa4eb9fa10729c /Makefile | |
parent | 01d509a48b467fa6e03d4af43b84bce835af4cef (diff) | |
download | linux-1e5ff84ffe0b09f866761c441003c27ca7e1c6b3.tar.xz |
scripts/gdb: do not descend into scripts/gdb from scripts
Currently, Kbuild descends from scripts/Makefile to scripts/gdb/Makefile
just for creating symbolic links, but it does not need to do it so early.
Merge the two descending paths to simplify the code.
Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1524,7 +1524,7 @@ $(DOC_TARGETS): scripts_basic FORCE PHONY += scripts_gdb scripts_gdb: prepare - $(Q)$(MAKE) $(build)=scripts/gdb/linux build_constants_py + $(Q)$(MAKE) $(build)=scripts/gdb ifdef CONFIG_GDB_SCRIPTS all: scripts_gdb |