diff options
author | Masahiro Yamada <yamada.masahiro@socionext.com> | 2019-03-26 09:32:16 +0300 |
---|---|---|
committer | Masahiro Yamada <yamada.masahiro@socionext.com> | 2019-04-01 04:06:00 +0300 |
commit | 0209987fc81c8118e9fc99a115a45b273e8acc75 (patch) | |
tree | 52854fdd779067eba1fbce29a4f089e1dac6bc7d /Makefile | |
parent | 669e06b19de8f844521a55afbdddbbccf26e5322 (diff) | |
download | linux-0209987fc81c8118e9fc99a115a45b273e8acc75.tar.xz |
kbuild: fix warning "overriding recipe for target 'Makefile'"
If you do "make Makefile" with GNU Make 3.x, the following warning
is displayed:
$ make Makefile
Makefile:165: warning: overriding recipe for target 'Makefile'
Makefile:51: warning: ignoring old recipe for target 'Makefile'
make[1]: Nothing to be done for 'Makefile'.
make: Nothing to be done for 'Makefile'.
Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -161,7 +161,7 @@ ifeq ($(need-sub-make),1) PHONY += $(MAKECMDGOALS) sub-make -$(filter-out _all sub-make $(CURDIR)/Makefile, $(MAKECMDGOALS)) _all: sub-make +$(filter-out _all sub-make $(lastword $(MAKEFILE_LIST)), $(MAKECMDGOALS)) _all: sub-make @: # Invoke a second make in the output directory, passing relevant variables |