summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorGopichand Paturi <gopichandpaturi@gmail.com>2024-06-19 14:16:00 +0300
committerGopichand Paturi <gopichandpaturi@gmail.com>2024-06-28 21:43:58 +0300
commitce34a2679f42cd266ef18bb34c532c402592af50 (patch)
tree285bf4a11e5c94bf9b76f547be36c191509086ef /meta-ibm
parentb001a52b39078057be61f9e812ba35c6cbc574cf (diff)
downloadopenbmc-ce34a2679f42cd266ef18bb34c532c402592af50.tar.xz
meta-phosphor: Reuse dreport utility function
install_dreport_user_script function is intended to be reused in meta-openpower layer. To enable this, the function is being moved to a bbclass which would be inherited in the openpower-debug-collector recipe in the meta-openpower layer. dreport.conf file is a variable, hence making it an argument to the function, so that other layer can give a custom dreport.conf as input. Tested: Verified that plugin scripts are getting installed from openpower-debug-collector repository and BMC Dump collection is successful. Change-Id: I8d13bc7e381cd1b957d5770926fb712165a07185 Signed-off-by: Gopichand Paturi <gopichandpaturi@gmail.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index df135f47f6..68fbf6051e 100644
--- a/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/meta-ibm/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -23,7 +23,7 @@ python link_ibm_plugins() {
op_plugins = os.listdir(source_path)
for op_plugin in op_plugins:
op_plugin_name = os.path.join(source_path, op_plugin)
- install_dreport_user_script(op_plugin_name, d)
+ install_dreport_user_script("dreport.conf", op_plugin_name, d)
}
#Install dump header script from dreport/ibm.d to dreport/include.d