summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service1
-rw-r--r--meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service19
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb25
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb3
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb20
6 files changed, 28 insertions, 44 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service b/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
index 77a88e864..825275ae7 100644
--- a/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
+++ b/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
@@ -8,6 +8,7 @@ Wants=obmc-power-on@%i.target
After=obmc-power-on@%i.target
Conflicts=obmc-host-stop@%i.target
ConditionPathExists=!/run/openbmc/host@%i-on
+ConditionPathExists=!/run/openbmc/mpreboot@%i
[Service]
ExecStart=/usr/bin/env openpower-proc-control startHost
diff --git a/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service b/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service
deleted file mode 100644
index bd9db809b..000000000
--- a/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=Run VCS workaround on host%i
-Wants=obmc-host-start-pre@%i.target
-Before=obmc-host-start-pre@%i.target
-Wants=obmc-power-on@%i.target
-After=obmc-power-on@%i.target
-Wants=fsi-scan@%i.service
-After=fsi-scan@%i.service
-Conflicts=obmc-chassis-poweroff@%i.target
-ConditionPathExists=!/run/openbmc/chassis@%i-on
-
-[Service]
-ExecStart=/usr/bin/env openpower-proc-control vcsWorkaround
-SyslogIdentifier=openpower-proc-control
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=obmc-chassis-poweron@%i.target
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8185ddf8f..9cb75f33e 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -14,12 +14,19 @@ ALLOW_EMPTY_${PN} = "1"
pkg_postinst_${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
TARGET="../op-stop-instructions@.service"
ln -s $TARGET $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
+ TARGET="../op-cfam-reset.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
TARGET="../op-cfam-reset.service"
ln -s $TARGET $LINK
@@ -30,16 +37,30 @@ pkg_postinst_${PN}() {
TARGET="../cfam_override@.service"
ln -s $TARGET $LINK
fi
+
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+ TARGET="../op-continue-mpreboot@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+ TARGET="../op-enter-mpreboot@.service"
+ ln -s $TARGET $LINK
}
pkg_prerm_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
rm $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
rm $LINK
# Only uninstall cfam override if p9 system
if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
rm $LINK
fi
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+ rm $LINK
}
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 01ef6b043..5fdbcaddb 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "7847960506ca4357e267fe05866b38aad236708f"
+SRCREV = "c98bab51d0826daeb8cf5fe1725c0e8932cb1996"
DEPENDS += " \
autoconf-archive-native \
@@ -34,4 +34,6 @@ SYSTEMD_SERVICE_${PN} += " \
op-stop-instructions@.service \
op-cfam-reset.service \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
+ op-continue-mpreboot@.service \
+ op-enter-mpreboot@.service \
"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 6905f34aa..84dc7b14a 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -11,8 +11,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "p9-vcs-workaround \
- op-proc-control \
+RDEPENDS_${PN} += "op-proc-control \
op-proc-control-systemd-links"
S = "${WORKDIR}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb b/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
deleted file mode 100644
index 29167b0e1..000000000
--- a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "POWER9 VCS workaround"
-DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-systemd
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
-RDEPENDS_${PN} += "virtual-p9-vcs-workaround op-proc-control"
-
-S = "${WORKDIR}"
-
-TMPL = "vcs_workaround@.service"
-INSTFMT = "vcs_workaround@{0}.service"
-TGTFMT = "obmc-chassis-poweron@{0}.target"
-FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"