summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/checkstop-monitor.bb10
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb28
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb8
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-cfam-override.bb8
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb10
6 files changed, 42 insertions, 24 deletions
diff --git a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
index 252773422..9f1828772 100644
--- a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
+++ b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
@@ -11,7 +11,7 @@ inherit autotools
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "pnorboot.service"
+SYSTEMD_SERVICE:${PN} += "pnorboot.service"
SRC_URI += "git://github.com/shenki/aspeed-lpc-control"
SRCREV = "af42b7ff01e71c0dd4c60214dd46ed487611f36d"
diff --git a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
index ebb3a2f77..9b1b1c4c5 100644
--- a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
+++ b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
@@ -7,25 +7,25 @@ inherit obmc-phosphor-systemd
inherit allarch
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
# For now, monitoring checkstop is the only usecase
OBMC_HOST_MONITOR_INSTANCES = "checkstop"
# Copies config file having arguments for monitoring host checkstop
# via GPIO assertion
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/checkstop"
# This package is not supplying the unit file and also this is not a native
# recipe since state-mgmt needs this package at runtime. Unsetting this below
# variable will let the build go through
-SYSTEMD_SERVICE_${PN} ?=""
+SYSTEMD_SERVICE:${PN} ?=""
# Install the override to set up a Conflicts relation
-SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
+SYSTEMD_OVERRIDE:${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
STATES = "startmin"
GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index c0132b80c..8cedb62a5 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit allarch
-RDEPENDS_${PN} += "op-proc-control"
-RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN} += "op-proc-control"
+RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
@@ -61,7 +61,17 @@ pkg_postinst_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
TARGET="../op-reset-host-check@.service"
ln -s $TARGET $LINK
- fi
+
+ mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ TARGET="../phal-import-devtree@.service"
+ ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
+ TARGET="../phal-export-devtree@.service"
+ ln -s $TARGET $LINK
+ fi
# If the memory preserving reboot feature is enabled, set it up
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
@@ -89,7 +99,7 @@ pkg_postinst_${PN}() {
fi
}
-pkg_prerm_${PN}() {
+pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
@@ -111,6 +121,12 @@ pkg_prerm_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 39a6f7bbb..cc464e30e 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "c3d6b876e7bf82df3dc023245c0622464dc4db42"
+SRCREV = "ee56c5552623e3908a3323bcdd6181ba750126a2"
DEPENDS += " \
phosphor-logging \
@@ -28,9 +28,9 @@ TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
+SYSTEMD_SERVICE:${PN} = "${TEMPLATE} ${INSTANCES}"
-SYSTEMD_SERVICE_${PN} += " \
+SYSTEMD_SERVICE:${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
op-stop-instructions@.service \
op-cfam-reset.service \
@@ -41,4 +41,6 @@ SYSTEMD_SERVICE_${PN} += " \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'proc-pre-poweroff@.service', '', d)} \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'op-reset-host-check@.service', '', d)} \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'op-reset-host-clear.service', '', d)} \
+ ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-import-devtree@.service', '', d)} \
+ ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-export-devtree@.service', '', d)} \
"
diff --git a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
index 769a1348d..d779785e4 100644
--- a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
-RDEPENDS_${PN} += "op-proc-control"
+FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
+RDEPENDS:${PN} += "op-proc-control"
S = "${WORKDIR}"
@@ -16,5 +16,5 @@ INSTFMT = "cfam_override@{0}.service"
TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 84dc7b14a..549bbe242 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
-RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
+RPROVIDES:${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "op-proc-control \
+RDEPENDS:${PN} += "op-proc-control \
op-proc-control-systemd-links"
S = "${WORKDIR}"
@@ -21,5 +21,5 @@ INSTFMT = "start_host@{0}.service"
TGTFMT = "obmc-host-startmin@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"