summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/lz4/lz4_1.9.0.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-05-29 19:22:39 +0300
committerEd Tanous <ed.tanous@intel.com>2019-05-29 19:22:39 +0300
commit5364646cb66fa75cdcbf148e039e0383cda94f2a (patch)
tree78b1711f353235e812435be90e124eab4037294e /poky/meta/recipes-support/lz4/lz4_1.9.0.bb
parent816d793003e93c1e5eec0a2e90fbd8b9dde9f7a5 (diff)
parent7b595c2f82912a170774e84e5bb81d1b6030bf6b (diff)
downloadopenbmc-5364646cb66fa75cdcbf148e039e0383cda94f2a.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'poky/meta/recipes-support/lz4/lz4_1.9.0.bb')
-rw-r--r--poky/meta/recipes-support/lz4/lz4_1.9.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/poky/meta/recipes-support/lz4/lz4_1.9.0.bb b/poky/meta/recipes-support/lz4/lz4_1.9.0.bb
new file mode 100644
index 000000000..744a1bf47
--- /dev/null
+++ b/poky/meta/recipes-support/lz4/lz4_1.9.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Extremely Fast Compression algorithm"
+DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
+
+LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
+LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
+ file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
+ "
+
+PE = "1"
+
+SRCREV = "131896ab9d4fc9b8c606616327ed223d5d86472b"
+
+SRC_URI = "git://github.com/lz4/lz4.git \
+ file://run-ptest \
+ "
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+
+do_install() {
+ oe_runmake install
+}
+
+BBCLASSEXTEND = "native nativesdk"