summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-05-29 19:22:39 +0300
committerEd Tanous <ed.tanous@intel.com>2019-05-29 19:22:39 +0300
commit5364646cb66fa75cdcbf148e039e0383cda94f2a (patch)
tree78b1711f353235e812435be90e124eab4037294e /meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb
parent816d793003e93c1e5eec0a2e90fbd8b9dde9f7a5 (diff)
parent7b595c2f82912a170774e84e5bb81d1b6030bf6b (diff)
downloadopenbmc-5364646cb66fa75cdcbf148e039e0383cda94f2a.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb
new file mode 100644
index 000000000..f78265030
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.1.1.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+HOMEPAGE = "https://pip.pypa.io/"
+LICENSE = "MIT & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
+
+SRC_URI[md5sum] = "4fb98a060f21c731d6743b90a714fc73"
+SRC_URI[sha256sum] = "44d3d7d3d30a1eb65c7e5ff1173cdf8f7467850605ac7cc3707b6064bddd0958"
+
+inherit pypi setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc"
+
+BBCLASSEXTEND = "native nativesdk"