summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-05-29 19:22:39 +0300
committerEd Tanous <ed.tanous@intel.com>2019-05-29 19:22:39 +0300
commit5364646cb66fa75cdcbf148e039e0383cda94f2a (patch)
tree78b1711f353235e812435be90e124eab4037294e /meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb
parent816d793003e93c1e5eec0a2e90fbd8b9dde9f7a5 (diff)
parent7b595c2f82912a170774e84e5bb81d1b6030bf6b (diff)
downloadopenbmc-5364646cb66fa75cdcbf148e039e0383cda94f2a.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb b/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb
new file mode 100644
index 000000000..b5c857329
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/catch2/catch2_2.7.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
+TDD and BDD - using C++11, C++14, C++17 and later."
+AUTHOR = "Phil Nash, Martin Horenovsky and others"
+HOMEPAGE = "https://github.com/catchorg/Catch2"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "git://github.com/catchorg/Catch2.git \
+ "
+# v2.7.2
+SRCREV = "7c37501b070c0e9ea9cdedbeac2059f0a6b0a8ab"
+
+S = "${WORKDIR}/git"
+
+inherit cmake python3native
+
+do_install_append() {
+ rm ${D}${datadir}/Catch2/lldbinit
+ rm ${D}${datadir}/Catch2/gdbinit
+ rmdir ${D}${datadir}/Catch2/
+}
+# Header-only library
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"