summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-phosphor/watchdog
diff options
context:
space:
mode:
authorVijay Khemka <vijaykhemka@fb.com>2020-03-04 22:29:09 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-05 04:44:19 +0300
commit001348a18193180988f6d1715be66f98e71b7f62 (patch)
tree702d3c812318e62954f1a49f12bbe53d01abd8dc /meta-facebook/recipes-phosphor/watchdog
parent60329ae7948afad0113799469efa212bba60b9b7 (diff)
downloadopenbmc-001348a18193180988f6d1715be66f98e71b7f62.tar.xz
meta-facebook: Move recipes-phosphor to facebook layer
Moved recipe-phosphor to meta-facebook to support multiple facebook platform and make use of common code across platforms. (From meta-facebook rev: 2b00ba0327fcef6ae98243bc48367b395460805f) Change-Id: If3b847b60c60d1d93c3c26be0018eb8408e4f93e Signed-off-by: Vijay Khemka <vijaykhemka@fb.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-facebook/recipes-phosphor/watchdog')
-rw-r--r--meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-cycle.service12
-rw-r--r--meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-poweroff.service9
-rw-r--r--meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-reset.service10
-rw-r--r--meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service16
-rw-r--r--meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend5
5 files changed, 52 insertions, 0 deletions
diff --git a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-cycle.service b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-cycle.service
new file mode 100644
index 000000000..3a22e56b9
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-cycle.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Power Cycle Host Server
+Requires=host-gpio.service
+After=host-gpio.service
+
+[Service]
+Type=oneshot
+ExecStart=busctl set-property xyz.openbmc_project.State.Chassis /xyz/openbmc_project/state/chassis0 xyz.openbmc_project.State.Chassis RequestedPowerTransition s xyz.openbmc_project.State.Chassis.Transition.Off
+ExecStart=busctl set-property xyz.openbmc_project.Control.Host.RestartCause /xyz/openbmc_project/control/host0/restart_cause xyz.openbmc_project.Control.Host.RestartCause RequestedRestartCause s xyz.openbmc_project.State.Host.RestartCause.WatchdogTimer
+ExecStart=sleep 6
+ExecStart=busctl set-property xyz.openbmc_project.State.Chassis /xyz/openbmc_project/state/chassis0 xyz.openbmc_project.State.Chassis RequestedPowerTransition s xyz.openbmc_project.State.Chassis.Transition.On
+SyslogIdentifier=phosphor-watchdog
diff --git a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-poweroff.service b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-poweroff.service
new file mode 100644
index 000000000..ddcb9dc62
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-poweroff.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Shutdown Host Server
+Requires=host-gpio.service
+After=host-gpio.service
+
+[Service]
+Type=oneshot
+ExecStart=busctl set-property xyz.openbmc_project.State.Chassis /xyz/openbmc_project/state/chassis0 xyz.openbmc_project.State.Chassis RequestedPowerTransition s xyz.openbmc_project.State.Chassis.Transition.Off
+SyslogIdentifier=phosphor-watchdog
diff --git a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-reset.service b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-reset.service
new file mode 100644
index 000000000..f0f03a1cc
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog-host-reset.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Reset Host Server
+Requires=host-gpio.service
+After=host-gpio.service
+
+[Service]
+Type=oneshot
+ExecStart=busctl set-property xyz.openbmc_project.State.Chassis /xyz/openbmc_project/state/chassis0 xyz.openbmc_project.State.Chassis RequestedPowerTransition s xyz.openbmc_project.State.Chassis.Transition.Reset
+ExecStart=busctl set-property xyz.openbmc_project.Control.Host.RestartCause /xyz/openbmc_project/control/host0/restart_cause xyz.openbmc_project.Control.Host.RestartCause RequestedRestartCause s xyz.openbmc_project.State.Host.RestartCause.WatchdogTimer
+SyslogIdentifier=phosphor-watchdog
diff --git a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service
new file mode 100644
index 000000000..f7e93b82f
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog/phosphor-watchdog.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Phosphor Watchdog
+
+[Service]
+ExecStart=/usr/bin/env phosphor-watchdog --continue --service=xyz.openbmc_project.Watchdog \
+ --path=/xyz/openbmc_project/watchdog/host0 \
+ --action_target=xyz.openbmc_project.State.Watchdog.Action.HardReset=phosphor-watchdog-host-reset.service \
+ --action_target=xyz.openbmc_project.State.Watchdog.Action.PowerOff=host-phosphor-watchdog-host-poweroff.service \
+ --action_target=xyz.openbmc_project.State.Watchdog.Action.PowerCycle=phosphor-watchdog-host-cycle.service \
+
+SyslogIdentifier=phosphor-watchdog
+BusName =xyz.openbmc_project.Watchdog
+Type=dbus
+
+[Install]
+WantedBy=basic.target
diff --git a/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
new file mode 100644
index 000000000..b0dcd093c
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/watchdog/phosphor-watchdog_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+# Remove the override to keep service running after DC cycle
+SYSTEMD_OVERRIDE_${PN}_remove = "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
+SYSTEMD_SERVICE_${PN} = "phosphor-watchdog.service phosphor-watchdog-host-poweroff.service phosphor-watchdog-host-reset.service phosphor-watchdog-host-cycle.service"